Metric Halo Discussion Forum
The place to talk MH!

Home   Search      Help    Register    Login
Home » Hardware » Interfaces » ULN-2 : Sketchy connection with MacBook Pro (Connection bugs between ULN-2 & MBP Retina)
ULN-2 : Sketchy connection with MacBook Pro [message #86083] Sun, 01 June 2014 18:01 Go to next message
BoogieMonsta is currently offline  BoogieMonsta
Messages: 2
Registered: June 2014
Junior Member
Hey there,

I've been using the ULN-2 for a few months now and I absolutely adore it.

However, I'm using it with my Retina MacBook Pro OS 10.8.5 via the Thunderbolt/FW800 adapter and the connection is not the greatest...
Without touching the cable or the adapter, I'd be working for hours without an issue and then all of a sudden no more sound.
At this point the only way for me to continue working is to unplug the ULN, restart my computer and replug it. A real PITA Sad

I've tried another cable, and another adapter. Doesn't make a difference.
This happens a few times a week.

Good news is, it forces me to take a short break.
Bad news is, well... It forces me to take a short break.

---

Also, I almost forgot to mention that when I'm done working and I unplug the ULN from my MBP, sometimes this causes the mac to bug out too. The ULN-2 disappears from the list of interfaces on the mac, but the mac can't switch back to its integrated sound card... It's like it's connected to a phantom interface (literally, it says it's connected to an interface but no name next to it). Replugging and Unplugging the ULN again doesn't change anything there either.

Sometimes it even freezes the mac... And then I have to either replug the ULN and hope that it unfreezes it (90% of the time) or in the rest of the cases I'm forced to do a hard reboot on the mac.

Any suggestions? Am I the only one with this problem?
Thanks in advance!

[Updated on: Sun, 01 June 2014 18:13]

Report message to a moderator

Re: ULN-2 : Sketchy connection with MacBook Pro [message #86180 is a reply to message #86083] Fri, 02 January 2015 13:30 Go to previous messageGo to next message
dustpandave is currently offline  dustpandave
Messages: 22
Registered: October 2012
Junior Member
Having the Exact same Problem here! Please Metric Halo can you give some feedback... this happened mid recording the best guitar take of my life and pro tools has to save and quit... It is one hell of a hinderance!

I thought it was Yosemite and ULN drivers but i see your using mountain lion

So has it got to do with thunderbolt to firmwire adapter?


Late 2011 MBP i7, 8 Gb RAM, OSX 10.8.2, Metric Halo ULN-2, Focal CMS65 Monitors
Re: ULN-2 : Sketchy connection with MacBook Pro [message #86181 is a reply to message #86180] Fri, 02 January 2015 15:50 Go to previous messageGo to next message
bj is currently offline  bj
Messages: 384
Registered: July 2011
Senior Member
Hi,

It doesn't have anything to do with Thunderbolt. This is actually a bug in Mac OS X and has been reported to Apple and acknowledged, but not fixed (it appeared in Mac OS 10.8.2).

The Apple bug number is rdar://13093900

I have discussed this further with Apple engineering and while there is no way for Metric Halo to fix this or patch around it, as it is a bug in Mac OS X, there is a user-level work-around that you can apply that will fix the problem for you while we wait for Apple to fix the root-cause.

The problem is occurring because of a change Apple made to the IO layer in Mac OS X to protect against physical access attacks via Firewire and PCIe (Thunderbolt). This is called VT-d (it is an intel technology built into the Processors and Chip Sets) and it virtualizes hardware access; in particular, it denys Memory Mapped peripherals access to all of the HW memory map except for buffers that have had specific access rights granted by the OS. Apple's FireWire driver is supposed to grant access to the FireWire hardware (Apple's -- not MH's) via their VT-d driver. The bug you are running into appears to be a hang or infinite loop in the VT-d driver while trying to allocate the access window.

So, the work around it to turn off VT-d.

To turn off VT-d, in the terminal type:

sudo nvram boot-args="dart=0x0"

and when it asks for your password, enter your password.

Then restart your Mac. This will make the problem go away.

B.J. Buchalter
Metric Halo

[Updated on: Fri, 02 January 2015 15:50]

Report message to a moderator

Re: ULN-2 : Sketchy connection with MacBook Pro [message #86182 is a reply to message #86181] Fri, 02 January 2015 17:11 Go to previous message
dustpandave is currently offline  dustpandave
Messages: 22
Registered: October 2012
Junior Member
Thanks BJ i will try that ASAP

Also - I might add.. I rest the PRAM and it hasn't bugged out for 3 hours now? is that just luck or did that do something good?


Late 2011 MBP i7, 8 Gb RAM, OSX 10.8.2, Metric Halo ULN-2, Focal CMS65 Monitors
Previous Topic: ULN8: Where to download the firmware?
Next Topic: 2882 and Bricasti
Goto Forum:
  

[ PDF ]

Current Time: Sun May 31 02:40:56 EDT 2020