Metric Halo Discussion Forum
The place to talk MH!

Home   Search      Help    Register    Login
Home » Hardware » Interfaces » Lost ULN-2 connection with Mac Pro 5,1 (edited)
Lost ULN-2 connection with Mac Pro 5,1 (edited) [message #86459] Thu, 24 November 2016 03:34
BrendanD is currently offline  BrendanD
Messages: 1
Registered: January 2016
Location: Oakland, CA
Junior Member
I guess I panicked too soon: it seems that my brand-new 9 pin-to-6 pin 10' FireWire cable was intermittent, still supplying power but not audio communication, though it had worked fine earlier. Fortunately, I had a 6' cable that worked. Also, I think that the weird UNL-2 power-on behavior (staying powered with computer and power supply both off) was due to a forgotten, powered-up-but-sleeping (silent) external FW hard drive supplying power to the FW bus through the turned-off Mac Pro's ports. I didn't realize that was possible, but it makes sense. So no need for assistance - for now, anyway!

Original post:
I've been using a ULN-2 with a Power Mac G5, and it's been working perfectly. I recently bought a used 2010 Mac Pro 5,1 running El Capitan 10.11.6, and picked up a 6 pin-to-9 pin FireWire cable to connect the ULN-2 to the new machine, which has no FireWire 400 ports. I've updated the unit's firmware to v5.0.45, and installed MIO Console and after a bit of messing with configuration, I got it all working perfectly with Digital Performer 8.07 and iTunes. So today I moved the new Mac Pro into my sound isolation box and reconnected everything, but I can no longer connect with the ULN-2; neither MIO Console, iTunes, Audio MIDI Setup, nor the Sound control panel see the unit any more. I tested a Firewire 800 external drive in the same port, and it works fine, so the Mac Pro's Firewire bus/ports seems to be working.

However, I noticed some odd behavior on power-up/power-down on the ULN-2. With the G5, the ULN-2 powered up from the FW connection, whether or not its power supply was connected. However, the "new" Mac Pro is one of those models with protective circuitry that won't allow the FW connection to power up the unit, so I have to use the power supply to start it up, then the Mac Pro will continue to power it even if you turn off the power supply. That's fine, and it worked exactly like that before today. But here's what I've seen today:

1) I turned on the Mac Pro, then turned on the ULN-2's power supply to start it up; all normal so far, the unit's lights light up normally, but it's not seen by the computer.

2) Turning off the ULN-2 power supply, the lights stay on, but still no connection.

3) I shut down the computer completely, intending to start it up and see if maybe it works this time. But - and this is where it gets weird - the ULN-2 stays lit up even the its power supply is turned off, as well as the computer! I unplugged the Mac Pro, and the unit's light went off; plugged it back in, and the unit lit up again - this is not normal! It seems the FW port is now supplying power when the machine is shut down, which it didn't before.

4) I did a few more computer shut down/start up cycles, and it started behaving normally again, except that th ULN-2 is still not seen.

5) Is it possible that the Mac Pro somehow fried my ULN-2's FireWire ports? Or does anybody have an idea what I can try to revive it? The whole setup worked perfectly before I reassembled everything in the iso box, and now it's dead. Help!

Thanks for any ideas.

[Updated on: Thu, 24 November 2016 05:03]

Report message to a moderator

Read Message
Previous Topic: power up problems with ULN-2
Next Topic: I think my fw 800 port maybe fried
Goto Forum:

[ PDF ]

Current Time: Wed Jun 07 19:10:47 EDT 2023